This page describes the additional software and infrastructure you'll need to run WebSpellChecker Server. Please review this info before installing WebSpellChecker Server. The information on this page applies to WebSpellChecker Server 5.0.0 and higher.

  • You should only use WebSpellChecker Server with a supported platform. Any platforms and versions not listed on this page are unsupported, which means we don't test, fix bugs or provide assistance. 
  • From time to time visit our blog to see if there are any End of Support Announcements for upcoming changes to supported platforms.

Please ensure you have read WebSpellChecker requirements, since not all the platforms listed below may be required for your specific WebSpellChecker setup.

Supported Platforms


Supported platform(s)Supported version(s)Notes
Operating systemsWindows Server
  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016
WebSpellChecker only officially supports WebSpellChecker running on x86 hardware and 64-bit derivatives of x86 hardware. 
Linux Distributives
  • Ubuntu Server with LTS 12.04+
  • CentOS 6.0+
  • Red Hat Enterprise Linux (RHEL) 6.0+
Cloud Computing PlatformsAmazon Web Services (AWS)

Microsoft Azure

Google Cloud Platform

Web serversInternet Information Services (IIS)7.0+
Apache HTTP Server2.2+
Application serversApache Tomcat7.0+
Oracle WebLogic Server11g (10.3.6), 12c (12.2.1+)
Oracle GlassFish Server

Java Runtime Environment (JRE)Windows1.8

Java 8 is required.

The older and newer versions of Java are not supported. The only supported version is Java 8.

WebSpellChecker AppServer will try to automatically detect Java Virtual Machine (JVM). If you prefer to setup or change a path to JVM manually, it can be done in AppServerX.xml configuration file using PathToJavaVirtualMachine parameter.

Linux1.8

Supported Browsers


Supported browser(s)Supported version(s)Notes
Web browsersChrome

Latest stable version supported


Microsoft Internet Explorer (IE)

9.0, 10.0, 11.0

Compatibility View mode in IEs is not supported.

Microsoft Edge12.0+

Compatibility View mode in IEs is not supported.

Mozilla Firefox

Latest stable version supported


Safari

Latest stable version supported on Mac OS X only


Mobile
Mobile devices are only supported on the Mobile views.