Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Problem and Symptoms

SCAYT and WebSpellChecker Dialog plugins for CKEditor 4 are installed on a localhost and throw the following error message:

Code Block
languagexml
{"error":true,"is_critical":1,"message":"sc","command":"The product 'scayt2_wsc_dialog' is not available 
or enabled for your subscription. 
Contact support@webspellchecker.net for more details."}

Solution

SCAYT 2 was officially deprecated, and is no longer supported as a part of WebSpellChecker free services. Here are the ways to solve the issue:

  • Upgrade to the latest version of CKEditor. The latest version of CKEditor 4 has built-in SCAYT 3 plugin. Thus, you can continue using the services for free but with certain limitations and a banner ad.
  • We recommend using WProofreader as an alternative solution compatible with older versions of CKEditor. 
  • If spelling and grammar check functionality is not required or is unpopular in your web applications, you can remove the plugins from CKEditor to get rid of errors in console. You can do it by adding the following option to CKEditor config.js file:
Code Block
languagexml
themeEmacs
config.removePlugins = 'wsc, scayt';
Note

In general, upgrading CKEditor and WebSpellChecker Dialog and SCAYT plugins help keep the products up-to-date and reliable.